当前位置: 首页 > PHP > 正文

帝国ecms升级为7.0后sql查询出错

在帝国cms的首页模板使用

[ecmsinfo]”select * from [!db.pre!]ecms_news where checked=1 order by diggtop desc,id desc limit 8″,8,30,0,24,21,0[/ecmsinfo]

来调用数据,原6.6正常显示,升级后出错,

SQL Error: select * from ***_ecms_news where checked=1 order by diggtop desc,id desc limit 8

把SQL复制到数据库后台运行出错,根据提示发现没有checked这个字段了,原来这个字段已不需要,升级把这个字段删除了。

把原SQL删除掉 where checked=1就OK。

[ecmsinfo]”select * from [!db.pre!]ecms_news  order by diggtop desc,id desc limit 8″,8,30,0,24,21,0[/ecmsinfo]

本文固定链接: http://cyq.me/1358 | 春与秋

该日志由 cyq 于2013年03月29日发表在 PHP 分类下, 通告目前不可用,你可以至底部留下评论。
原创文章转载请注明: 帝国ecms升级为7.0后sql查询出错 | 春与秋
关键字: ,

帝国ecms升级为7.0后sql查询出错:等您坐沙发呢!

发表评论

快捷键:Ctrl+Enter